Thetford Toilet Flush Pump Running

Including self-containment
PauanuiMac
Posts: 1
Joined: Wed Oct 01, 2014 7:20 pm
NZMCA No: 54490

Thetford Toilet Flush Pump Running

Postby PauanuiMac » Wed Sep 02, 2015 2:03 pm

A strange one. Went down to get the car out of the garage this morning and heard a strange noise coming from the caravan parked near the garage. Turns out it was the toilet flushing pump running. I was running short of time, so pulled the cassette out and pulled the fuse out for the pump.
After I got back home I dried out the cassette cavity, refilled the flush tank, replaced the fuse and everything seems normal.

Question - what has caused the pump to start. The caravan hasn't been used for several months, and no-one has been in the caravan recently. We did have a big storm with torrential rain the last few days, but the van has a cover on it and there was no evidence of any rain water inside ??

Anyone got any ideas ??

User avatar
Doit
Supporter
Supporter
Posts: 1361
Joined: Sun Nov 28, 2010 3:22 pm
NZMCA No: 13693
Location: Hamilton

Re: Thetford Toilet Flush Pump Running

Postby Doit » Wed Sep 02, 2015 2:20 pm

My guesses would be the micro switch on the flush button named on. Check the flush button springs back when pushed.
Trevor
NZMCA member, 2005 Canter 3.6l. 370w solar. 220AH Gel house,195l Fresh/150l grey. VSR,12v Equaliser charger, 7 stage 240v charger, 1000w mod sine inverter, 300w pure sine inverter, 12v Vitrfrigo 90l fridge. Webasto diesel heater. Thetford WC.

User avatar
kiwipete
Supporter
Supporter
Posts: 208
Joined: Sat Oct 06, 2012 5:06 pm
NZMCA No: 49321
Location: Christchurch

Re: Thetford Toilet Flush Pump Running

Postby kiwipete » Thu Sep 03, 2015 6:35 am

Google your problem as I recall reading something about this a long time ago?
Ok people, move along. Nothing to see here. Thank you, move along.
Ph 0212078472

NZMCA No.49321


Return to “Plumbing”

Who is online

Users browsing this forum: No registered users and 2 guests