Including self-containment
 #100199  by Bill
 Wed Sep 23, 2015 11:56 pm
It may be that the switch hasa broken wire. This happened to our toilet when we were in Invercargill last summer. The fixit people at the motorhome shop said it was not uncommon and repaired it in less than an hour. It was fiddilly to get at.
 #101483  by Hugh
 Sun Oct 18, 2015 9:40 pm
Thanks all for advice. A bit fiddly but all good and new flush pump working well.
 #117861  by Coast2Coast
 Thu Sep 01, 2016 11:03 am
For the past 4 years we have had the problem of the Thetford flush pump being very reluctant to go properly at the start of every trip. We have had to hold the switch on for 10 to 30 seconds before the pump would start and then slowly get up to full speed. It would then be OK while regularly using. Tried all sorts of fixes and internet enquiries. Yesterday found a different solution on the internet which suggested that the pink Thetford Aqua Flush we were using was the problem in that it builds up gunk in the pump impeller. Recommended solution was to use detergent in the flush tank to dissolve the gunk, which I did (plus added some bleach for good measure). Tried the pump today and it works perfectly and when it started it discharged quite an amount of brown dissolved gunk. Hopefully fix is permanent. If so then decision is to change to another type of flush solution or else just use some detergent (and bleach?) in the flush tank. Anyone else been down this route? :)
 #117864  by scubadoo
 Thu Sep 01, 2016 12:11 pm
Water only has worked perfectly for us but it is used every day. Any "gunk" has long gone.
 #117942  by Zukiwi
 Fri Sep 02, 2016 10:49 pm
We only put water in the top tank and laundry whitener (oxidiser) in the cassette. Works fine as long as you don't leave it more than about 4 days in warm weather and of course no pump problems and you can safely empty cassette into a septic tank system without compromising the biological activity. You can add a bit more oxidiser if needed for longer cycles.

 #118377  by Zukiwi
 Sun Sep 11, 2016 10:04 pm
Well how things can come back to haunt you so easily :shock:

Following my post a few days ago about the perfect operation of our Thetford flush pump, we went away for the weekend in the motorhome, the first trip since Easter. Thetford flush pump wouldn't go. Checked the obvious and found the fuse blown. Replaced fuse, blew again. So the process of elimination began and of course I'd left my multi meter at home (it lives in the motorhome) :oops: After I'd checked the power feed and microswitch I finally got into the pump and sure enough, the impeller was seized. With a bit of gentle persuasion from a fine bladed screwdriver got it moving again and all is good.

While in the flush tank I also noted the brown slime on several surfaces mentioned by others, although I don't think this was blocking my pump as it happily discharged it into the bowl later - it seemed more like corrosion or perhaps a bit of solid debris (pumice?) binding it, rather than a soft material. Perhaps a caution to be careful in sourcing water for the flush tank. In the past I'd got it from streams and lakes to avoid using tank water when freedom camping and may have picked up a bit of grit.

The only other thing done differently in the last year was taking part in a user trial of a new toilet treatment product over summer which included a top tank treatment as well as a cassette additive (unknown compounds). I have no evidence that this may have caused this issue, but am happy to now be reverted to our fresh flush water and oxidiser in the cassette.

Pay with Paymate Express