#145103  by Neddy
 Sat Oct 06, 2018 6:18 am
Ideally, the device should be set to the Float voltage recommended by the manufacturer of your starter batteries. For most 24v Lead/Calcium batteries, this will be between 27.2 and 27.8 volts.
 #145205  by justus
 Tue Oct 09, 2018 6:52 pm
Evening all
Like one or two others my panel voltage is two high for direct connection to the unit.
I have two Votronic MPP350 controllers. One of the ancillary connections is a 2amp 12V start battery charge connection. Can I use this connection as the input to the unit. If so are there any other precautions I need to take?

TIA :TU
 #145208  by Neddy
 Tue Oct 09, 2018 8:17 pm
Since Votronic controllers have the conventional "Negative Earth" configuration, your idea should work OK. Because you would be using a "current limited" source, the device does not really need to provide current limiting as well.

Neville.
 #145522  by MikeDennehyNZ
 Fri Oct 19, 2018 11:11 am
Hi, hoping someone can help me with a question about a battery charger. I have a new (replaced under warranty) Powertrain 4 Amp 24V Automatic 3 Stage Smart Battery Charger, which is hard-wired in the campervan under the glovebox.

There are two lights permanently on - Power and Fully Charged. Should these be on all the time even when the charger is not plugged in, and if so, is it drawing current from the starter battery, and should I be concerned about that?

I'll wait until the Fully Charged light goes out and plug it in to the mains and see if it starts charging as it should do, but it's a concern that the battery charger is helping to flatten the battery when it's not plugged in. We have previously noticed that if we don;t start the van for a day or two, the starter motor barely turns over. Once running for a few minutes, it starts fine.

Any suggestions gratefully received. I did not get a manual with the charger and can't find one online, so I don't know what state it should be in at rest, if that makes sense.

Many thanks
Mike
 #145523  by Mark
 Fri Oct 19, 2018 11:16 am
Mike
I no longer know how to split your post out from this thread and create a new one for it.
It would be great if you could open a new thread for your question and copy and paste the text below into it.
This existing thread is a slightly different topic.
 #145866  by justus
 Wed Oct 31, 2018 5:46 pm
Evening all.
Have connected my unit to the start battery output from one of my Votronic MPP 350 controllers.
I first ran the unit up on a test bench with a 12V supply set the output to 27.4V.
Question for the wide..
The unit has a fault (red) led at the input end and an OK (green) led at the output end of the board.
Now connected to the controller and start battery, I have noticed that while the OK led is shining bright, the fault led is also on although very dim, any thoughts or ideas.
TIA :TU
 #145892  by justus
 Thu Nov 01, 2018 9:42 am
Now the unit has been running for a day and has done a couple of cycles. I have noted that when the battery reaches float at 27.3 the dim red led goes out.
After a start or first thing in the morn when the V is around 25.9 the dim red led is on.

Works a treat, thanks again Neville!!
 #145969  by justus
 Sat Nov 03, 2018 6:19 am
Morning all I managed to find some info online in case anyone is interested.
Once the unit is running and the green led is lit. The fault (red) led, becomes an output under voltage indicator. So any time you are under your set float voltage the red led will be on, but dim :TU
  • 1
  • 19
  • 20
  • 21
  • 22
  • 23
Pay with Paymate Express